Announcement

Collapse
No announcement yet.

Starting issues

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Starting issues

    I own a '98 grand marquis. My problem is on start up the engine starts then stalls when key is released to run position. Any ideas where to start looking. Same condition in park or neutral.

    #2
    I'm not an expert with whale stuff but since the guru's haven't commented yet, I will. Maybe the ignition switch is bad? Does it eventually run? What is the idle quality like? If it's fine and not throwing any trouble codes I'd look at the ignition switch.
    1989 Lincoln Town Car

    Comment


      #3
      sounds like the switch could be flaky, or its worn to the point that when you release it, the spring return pushes it past "on" back to "off". Does it keep running if you rotate it back from the start position to the on position rather than releasing the key and letting it return on it's own?

      Other possible is the IAC is sticky, and its closing too far to keep the engine running. A little gas pedal would tell you if thats whats going on. If you can keep it running with the pedal, the idle controller is goofy.

      86 Lincoln Town Car (Galactica).
      5.0 HO, CompCams XE258,Scorpion 1.72 roller rockers, 3.55 K code rear, tow package, BHPerformance ported E7 heads, Tmoss Explorer intake, 65mm throttle body, Hedman 1 5/8" headers, 2.5" dual exhaust, ASP underdrive pulley

      91 Lincoln Mark VII LSC SE, triple black (Timewarp) - poly front bushings, KYB struts and shocks, Holley SystemMax1 lower intake, SilverFox AOD valve body,

      1984 Lincoln Continental TurboDiesel - rolls coal

      Originally posted by phayzer5
      I drive a Lincoln. I can't be bothered to shift like the peasants and rabble rousers

      Comment


        #4
        Thanks for the help. I went through the usual fuel and spark, both good. No CEL. While checking vacuum hoses found it would run with PCV hose removed. Checked IAC, working ok. Pulled aircleaner lid, checked MAF, found spider made a home in port. Spider access gained through ill fitting lid on aircleaner. Next job sealing or replacing aircleaner!
        Thanks again.

        Comment


          #5
          spider in the MAF could explain it. They get real dumb when things are dirty or plugged up down there.

          86 Lincoln Town Car (Galactica).
          5.0 HO, CompCams XE258,Scorpion 1.72 roller rockers, 3.55 K code rear, tow package, BHPerformance ported E7 heads, Tmoss Explorer intake, 65mm throttle body, Hedman 1 5/8" headers, 2.5" dual exhaust, ASP underdrive pulley

          91 Lincoln Mark VII LSC SE, triple black (Timewarp) - poly front bushings, KYB struts and shocks, Holley SystemMax1 lower intake, SilverFox AOD valve body,

          1984 Lincoln Continental TurboDiesel - rolls coal

          Originally posted by phayzer5
          I drive a Lincoln. I can't be bothered to shift like the peasants and rabble rousers

          Comment

          Working...
          X