Announcement

Collapse
No announcement yet.

Cfi running issues

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Cfi running issues

    My 85 cfi car keeps having hiccups going down the highway and dying when I come to a stop sometimes after it sat for a week. What would cause this? I changed the fuel filter about 800 miles ago when I first got the car

    #2
    Those are some of the primary problems I was dealing with on my '84 CFI car (same system but there are different ECM codes between 84 and 85) which had me go through the entire engine management system. I never identified what one specific thing I replaced that fixed the problem.

    My suggestions for things to check:
    • Check for codes but do not go crazy trying to fix them, just post them here so we have some idea what the computer is thinking (it is much smarter than the EEC-III computer and is definitely worth paying attention to; when people say CFI has a dumb computer, this is not the system they are talking about)
    • Check for charging voltage at battery with engine at lowest idle speed (make sure you see something like 13.8V-14.5; it is normal with the 1G alternator to lag behind a bit at idle but should still be upper 13V range, if it's under 13 you're going to have issues)
    • Visually inspect battery main battery cables, and the other end of the ground cable
    • Inspect wiring going into fuel pump relay, if it looks kind of melted, that is a clue that the fuel pump is pulling too much current (is not aging well)
    • Fuel pressure when the pump is cold
    • Fuel pressure when the pump is hot (running for a while like after a drive on the highway)
    • Fuel pressure when the car is misbehaving e.g. you just limped it home and it barely wants to stay running
      (when my fuel pump was weak but still making enough pressure to run, it would misfire at highway speed, particularly if I tried to lean into the throttle to gain speed)

    Current drivers: 84 TC | 85 CS
    Panthers, Parked: 83 GM 2dr | 86 GM | 88 TC | 91 GM
    Not Panthers: 85 Ranger | Ranger trailer | 05 Focus
    RIP: 97 CV | 83 TC | 04 Focus | Junkyards

    Comment


      #3
      I notice when it's acting up it smells like fuel/running rich but no leaks on the ground or anything

      Comment


        #4
        One of the fittings on the fuel filter had slipped off a little bit and since I pushed it back on it seems to be running better

        Comment

        Working...
        X